Outils pour les Historiens (L3H)

Changer le monde, un site à la fois…

Sidebar
Menu
Description des vidéos associées à Excel


(excel.seance1.poly.pdf)

S1.A
Lancement de Excel.
Visionnage rapide des menus.
Une feuille de tableur est un ensemble de cellules.
Nous balayons les cellules A1, B1, C1,D1,A2.
Chaque cellule peut contenir : un texte, un nombre ou une formule.

Nous allons essayer de réaliser une feuille de calcul nous permettant de savoir ce que l'on veut / peut commander pour notre Nöel .

On entre du texte dans les cellules A1, A2,A3, B2,C2,D2.
On entre des nombres dans B3,B5,B6,B7 et dans C3,C4,C5,C6.

Les cellules contenant le prix total TTC (D3,D4,D5,D6) reçoivent directement les valeurs calculées par l'opérateur. On perd l'intérêt et la puissance d'un tableur.

On constate même que lorsque l'on modifie les quantités, les totaux ne sont pas mis à jour.

D'où l'intérêt des cellules avec formules.

On va indiquer que la cellule D3 va contenir le résultat de B3 * C3.
Pour entrer une formule dans une cellule, on sélectionne la cellule, puis on tape sur la touche '=' pour commencer à entrer la formule. On peut se servir de la souris pour indiquer les noms des éléments faisant partie de la formule.

D3 = B3* C3

On refait de même avec les autres cellules.

S1.B
On découvre que l'appellation A1, B1, etc .. pour les cellules est une façon de nommer les cellules.
Un autre mode d'appellation des cellules A1, B1 est disponible en cochant la case "Style de référence L1C1" dans le menu "Outils/option" de Excel.
Ainsi, la cellule D3 s'appelle aussi "L3C4" (Ligne 3 Colonne 4).
Regardez à quoi est égal L3C4 (ex D3)

L3C4=LC(-2)*LC(-1)

LC(-2) par rapport à L3C4 est égal à L3C2(c'est à dire B3).
LC(-1) par rapport à L3C4 est égal à L3C3(c'est à dire C3).
D3 = B3 * C3

En parcourant les autres cellules formules, on constate que l'on a la formule "=LC(-2)*LC(-1)".
Si je copie et colle cette formule dans les lignes blanches suivantes, je prépare de nouvelles lignes.

S1.C

Il serait intéressant d'avoir le cumul de ma commande.
D20=D4+D5+...+ D19
Cette formule est astreignante.
Il y a risque d'oubli.
On pourra utiliser "=somme(D3:D18)



S1.D
Utilisation d'une formule plus compliquée.
Le résultat d'une cellule dépend d'une valeur mise dans la colonne B.
La formule introduite est la suivante : " = SI(B3="*" ; C3*D3 ; 0 ) "
Cela veut dire : si la case B3 est égal au caractère "*", la cellule aura comme résultat 0. Dans le cas contraire, c'est le produit de Qtité par PrixUnitaireTTC.
Résultats obtenus : les "*" permettent de dire que les produits "cochés" sont sélectionnés.

S2.A
Simulation de la gestion d'un compte chèque.

F5 = C2+D5-E5 (= solde initial + crédit - débit)
Entrée de la deuxième ligne : F6 = F5+D6-E6 = solde précédent+crédit-débit

Recopie de la formule.

Notez l'aspect gênant de la répétition des mêmes valeurs de soldes.



S2.B
F10=SI( ET(D10=0;E10=0); "" ; F9+D10-E10)

On recopie la formule de la 2ème ligne à la n ème ligne que l'on veut.
Admirez le résultat.

S3.A
Relevé de notes d'élèves.

Utilité d'un tableur pour calculer automatiquement la note finale sur 20 d'un devoir..

S3.B
Relevé de notes d'élèves.
Utilisation du tri pour permettre de connaître le classement des élèves.

S4
Tri suivant différentes colonnes.

S5.A
Courbes.
Evolution du prix d'un voyage en fonction des années.
Modification des options du graphique.
S5.B
Notez le changement des valeurs et répercussions sur le graphique.
S5.C
Ajout de nouvelles données au graphique.


S6
Histogramme de mesure de performances
Lien vers la séance 2

Exo1
Tri - Filtrage et grille

Exo2
Notes avec coefficients

Exo2B
Copier/Coller avec des valeurs.
Utilisation du collage spécial. Test du collage avec "transposition"

Exo3
Importation et exportation de La France


Retour sur les statistiques

- Calcul de fréquences (exoFrequence.xls)

- exoPourStatophobes.xls
Avant de faire l'exercice ci-dessus, lisez cet extrait de Statistiques pour les Statophobes (de D.Poinsot)


Découverte de quelques fonctions utiles.

-> fonctionsUtiles.xls


Importation et exportation de données

texteNotesEleves.txt

autreTexteAImporter.csv

autreTexteAImporter.txt




Tableaux croisés dynamiques

- http://lecompagnon.info/excel/tableaucroise.htm

-> exo.tcroise1.xls

http://excel.doublevez.info/tableauCroiseEnonce.htm

-> exo.tcroise2.xls



Autres références

- initiation à Excel (2010) (http://issuu.com/emilienruiz/docs/excel2010_-_introduction)

- Utiliser Excel pour gérer des bases historiques

- Un ouvrage à lire absolument : Statistiques pour les Statophobes (de D.Poinsot)
(Lien direct pour le téléchargement -> ici ou )
( un petit extrait à lire absolument)


Ajout de dernière minute
exoPyramide.xls